<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":782,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81720434-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>CaliforniaPreps.com  -  Rivals Rankings Week: Breaking down the 2019 wide receivers</title>
<meta content='CaliforniaPreps.com  -  Rivals Rankings Week: Breaking down the 2019 wide receivers' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-d260ff1471a6492ce98232dc5bdecce059513f952119a23fccca7df675887cdd.css" />


<script src="https://cdn.rivals.com/production/assets/lib-ce195dceed0b4a3a176cf70ba9222fa0366faf6b3e6941a44c576682b5a595a8.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-adb546134453c7f4c6a2aef70bd87054b0132aece2bc818d90e3f0941d09b5b5.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="FPJHjdh+r04y0h74ThYuz97wEHAH3Us+lBIT4wQsA5uohDA42oXNF/U9UveHFAt5WR6aBe2H9vOtAfbOpfIZeg==" />
<script>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</script>
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://californiapreps.rivals.com/news/rivals-rankings-week-breaking-down-the-2019-wide-receivers' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_hero_desktop/ry7bycnnjx241sw1caao' property='og:image'>
<meta content='Five-stars Theo Wease and Trejan Bridges give Oklahoma a potent 1-2 punch at receiver.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-12-06 10:46:31 -0600' property='article:published_time'>
<meta content='2018-12-06 19:48:24 -0600' property='article:modified_time'>
<meta content='Article' property='article:section'>
<meta content='Cornelius Johnson' property='article:tag'>
<meta content='Elijah  Higgins' property='article:tag'>
<meta content='Bru McCoy' property='article:tag'>
<meta content='Kyle Ford' property='article:tag'>
<meta content='Puka Nacua' property='article:tag'>
<meta content='Ethan Rae' property='article:tag'>
<meta content='Jude Wolfe' property='article:tag'>
<meta content='Drake London' property='article:tag'>
<meta content='Brannon Spector' property='article:tag'>
<meta content='Davis Allen' property='article:tag'>
<meta content='Jaelyn Lay' property='article:tag'>
<meta content='Frank Ladson' property='article:tag'>
<meta content='Joe Ngata' property='article:tag'>
<meta content='Austin Stogner' property='article:tag'>
<meta content='Trejan Bridges' property='article:tag'>
<meta content='Theo Wease' property='article:tag'>
<meta content='Kenyon Jackson' property='article:tag'>
<meta content='Kam Brown' property='article:tag'>
<meta content='Dylan Wright' property='article:tag'>
<meta content='Baylor Cupp' property='article:tag'>
<meta content='Josh Delgado' property='article:tag'>
<meta content='Patrick Herbert' property='article:tag'>
<meta content='Mycah Pittman' property='article:tag'>
<meta content='Lance Wilhoite' property='article:tag'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "californiapreps.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='californiapreps contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .californiapreps #programming > h1 {
      background-color: #8c008c !important; } }
  .californiapreps > header .notification-link .count-container {
    background-color: #8c008c !important; }
  .californiapreps > header .wrapper-container {
    background-color: #8c008c !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .californiapreps > header .wrapper-container {
        border-bottom: 5px solid #cece00 !important; } }
  .californiapreps > header .invalid-email-banner {
    background-color: #8c008c;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .californiapreps > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .californiapreps > header .invalid-email-banner a:hover {
      color: #cece00; }
  @media screen and (max-width: 767px) {
    .californiapreps > header .mobile-header {
      background-color: #cece00 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .californiapreps > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .californiapreps > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .californiapreps > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .californiapreps > header .nav-row > ul,
    .californiapreps > header .third-nav {
      background-color: white !important; }
    .californiapreps > header .dropdown-toggle > i.fa {
      color: #8c008c !important; } }
  .californiapreps > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #8c008c; }
  
  .site-primary-font-color {
    color: #8c008c; }
  
  .site-primary-background-color {
    background-color: #8c008c; }
  
  .site-secondary-font-color {
    color: #cece00; }
  
  .site-secondary-background-color {
    background-color: #cece00; }
  
  :root {
    --outbrain-primary-color: #8c008c;
    --outbrain-secondary-color: #cece00; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="California HS Sports" class="school-header" href="https://californiapreps.rivals.com/"><span class='header-text'>
        CaliforniaPreps.com
      </span>
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://californiapreps.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;californiapreps&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://californiapreps.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;californiapreps&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022719647,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Rivals Rankings Week: Breaking down the 2019 wide receivers"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='rivals' name='twitter:site'>
<meta content='Rivals Rankings Week: Breaking down the 2019 wide receivers' name='twitter:title'>
<meta content='Five-stars Theo Wease and Trejan Bridges give Oklahoma a potent 1-2 punch at receiver.' name='twitter:description'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ry7bycnnjx241sw1caao' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":18,"legacy_id":968,"name":"CaliforniaPreps.com","friendly_name":"California HS Sports","annual_discount":null,"subdomain":"californiapreps","primary_color":"8c008c","secondary_color":"cece00","font_color":"ffffff","short_name":"californiapreps","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81720434-1"}, true, 245, nil, {"id":3,"primary_color":"8c008c","secondary_color":"cece00","font_color":"ffffff","commitment_module_football":false,"rivals_module_football":false,"header_name":"","header_logo_cloudinary":null,"mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81720434-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":18,"created_at":"2016-11-23T13:38:41.261-06:00","updated_at":"2018-09-04T01:23:38.278-05:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://californiapreps.forums.rivals.com","scoreboard_scores_id":15083,"scoreboard_photos_id":15084,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":true,"display_fb_follow":true,"follow_twitter_handle":"davekeefer","follow_fb_handle":"dave.keefer.7","forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":10,"schedule_header_on":true},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #8c008c'>
Ticker
</div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://californiapreps.rivals.com/news/rivals-rankings-week-breaking-down-the-2019-wide-receivers' background-color='#8c008c' base-api-url='https://californiapreps.forums.rivals.com/' homepage='false' message-board-url='https://californiapreps.forums.rivals.com' pub-ad='null' size='size' space-id='2022719647' subscribed-user='subscribedUser'></rv-homepage-forums>

<div class='ads'>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://californiapreps.rivals.com' data-widget-id='AR_4' in-side-rail='true' rv-add-class-at-top='fixed-top' sibling-container='article-display-wrapper' top-padding='0'>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>
</div>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://californiapreps.rivals.com/news/rivals-rankings-week-breaking-down-the-2019-wide-receivers/printable' site-name='CaliforniaPreps.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-12-06 10:46:31 -0600') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1991305/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Rivals Rankings Week: Breaking down the 2019 wide receivers</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/pxxbqpakwu8cwswywiqd'>
<span>
<span class='title-sm'>
Adam  Friedman
&bull;
</span>
<a class='type-sm' href='{{editPath(subdomain)}}'>Rivals.com</a>
<div class='type-sm'>
<a href='//twitter.com/RivalsFriedman' target='_blank'>@RivalsFriedman</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Recruiting Analyst</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/RivalsFriedman'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
Adam Friedman joined Rivals.com as the Mid-Atlantic Recruiting Analyst in 2012 and covers D1 CFB recruits from NC to Maine &amp; out to PA &amp; WV. Media requests- RivalsFriedman@yahoo.com
</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p><b>CLASS OF 2019 RANKINGS:</b> <a href="https://n.rivals.com/prospect_rankings/rivals250/2019">Rivals250</a> | <a href="https://n.rivals.com/news/rivals-com-s-class-of-2019-state-rankings">State</a> | <a href="https://n.rivals.com/news/rivals-2019-position-rankings">Position</a> | <a href="https://n.rivals.com/team_rankings/2019/all-teams/football">Team</a></p><p><b>CLASS OF 2020 RANKINGS: <a href="https://n.rivals.com/prospect_rankings/rivals250/2020">Rivals250</a> | <a href="https://n.rivals.com/news/class-of-2020-state-rankings">State</a> | <a href="https://n.rivals.com/news/class-of-2020-position-rankings">Position</a><br></b></p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ry7bycnnjx241sw1caao)'></div>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ry7bycnnjx241sw1caao" alt="Ry7bycnnjx241sw1caao" />
</div>
<figcaption class='image-caption'>Theo Wease</figcaption>
<div class='image-credit'></div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>Senior seasons are almost finished and the postseason update to the Rivals position rankings is rolling out. There were a lot of moves in the wide receiver and tight end rankings and some huge decommitments have set the stage of a wild run to the Early Signing Period and to Signing Day. Here is a look at the landscape now the newest rankings update has come out.</p><p><b>More Rivals Rankings Week:</b></p><p><b>Monday</b>: <a href="https://n.rivals.com/news/rivals-rankings-week-top-10-for-2019-class-revealed">Updated Top 10</a> | <a href="https://n.rivals.com/news/rivals-rankings-week-ranking-smith-vs-thibodeaux">Debating Smith vs. Thibodeaux</a></p><p><b>Tuesday</b>: <a href="https://n.rivals.com/news/four-new-five-stars-join-the-2019-rivals100">2019 Rivals100 revealed</a><b> | <a href="https://n.rivals.com/news/mind-of-mike-class-of-2019-rivals100-updated">Mind of Mike</a></b></p><p><b>Wednesday</b>: <a href="https://n.rivals.com/news/new-rivals250-released-analysts-weigh-in-on-toughest-decisions">2019 Rivals250 revealed</a></p><p><b>Thursday</b>: <a href="https://n.rivals.com/news/rivals-2019-position-rankings">2019 position rankings revealed</a></p>
</div>
<h3 class='article-heading'>TEAMS WITH TOP COMMITS: Clemson, Oklahoma, Oregon, Texas A&amp;M</h3>
<div class='st__content-block st__content-block--text article-text'>
<p>It's hard to name which one of these teams, the same four from the preseason rankings update, has the best class of receivers and tight ends. </p><p><a href="https://oregon.rivals.com/">Oregon</a>, with receivers <a href="https://n.rivals.com/content/prospects/2019/lance-wilhoite-105169">Lance Wilhoite</a> and <a href="https://n.rivals.com/content/prospects/2019/mycah-pittman-182490">Mycah Pittman</a> in the Rivals100 along with tight end <a href="https://n.rivals.com/content/prospects/2019/patrick-herbert-182227">Patrick Herbert</a> and receiver <a href="https://n.rivals.com/content/prospects/2019/josh-delgado-69169">Josh Delgado</a> in the Rivals250, is the only program in the country that can boast two pass catchers in the Rivals100 and two in the Rivals250.</p><p><a href="https://tamu.rivals.com/">Texas A&amp;M</a> has four commits in the Rivals250. <a href="https://n.rivals.com/content/prospects/2019/baylor-cupp-211625">Baylor Cupp</a>, the No. 2 tight end in the country, leads the Aggie commits at No. 128 in the Rivals250 followed closely by receiver <a href="https://n.rivals.com/content/prospects/2019/dylan-wright-190489">Dylan Wright</a>. <a href="https://n.rivals.com/content/prospects/2019/kam-brown-183324">Kam Brown</a> and <a href="https://n.rivals.com/content/prospects/2019/kenyon-jackson-30525">Kenyon Jackson</a>, both receivers, join them in the Rivals250.</p><p><a href="https://oklahoma.rivals.com/">Oklahoma</a> has the best one-two punch at wide receiver. Five-stars <a href="https://n.rivals.com/content/prospects/2019/theo-wease-37768">Theo Wease</a> and <a href="https://n.rivals.com/content/prospects/2019/trejan-bridges-182880">Trejan Bridges</a>, Nos. 1 and 4 in the wide receiver rankings, will be making plays for the Sooners for years to come. <a href="https://n.rivals.com/content/prospects/2019/austin-stogner-185030">Austin Stogner</a>, the No. 4 tight end in the Rivals250, gives the Sooners more of a presence in the Rivals250.</p><p>The only wide receiver duo that can really challenge Oklahoma's are <a href="https://clemson.rivals.com/">Clemson</a>'s <a href="https://n.rivals.com/content/prospects/2019/joe-ngata-182067">Joseph Ngata</a>, a new five-star, and <a href="https://n.rivals.com/content/prospects/2019/frank-ladson-184832">Frank Ladson</a>, the No. 7 receiver in the rankings. The Tigers and Sooners are the only teams with two receivers in the top 40 of the Rivals100. <a href="https://n.rivals.com/content/prospects/2019/jaelyn-lay-206605">Jaelyn Lay</a>, the No. 5 tight end in the rankings and another Clemson commit in the Rivals250, helps add some size to this Clemson recruiting class. The Tigers also hold commitments from three-stars <a href="https://n.rivals.com/content/prospects/2019/davis-allen-215443">Davis Allen</a>, ranked No. 28 in the tight end rankings, and <a href="https://n.rivals.com/content/prospects/2019/brannon-spector-39612">Brannon Spector</a>, the No. 86 wide receiver in the rankings.</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='http://clemson.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/gevcuarvpvkebl4lfxxc)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/gevcuarvpvkebl4lfxxc" alt="Gevcuarvpvkebl4lfxxc" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<figure class='article-image'>
<div class='blurred-image'>
<a href='http://oklahoma.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ijnpfm57do8uoy2cxjsc)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ijnpfm57do8uoy2cxjsc" alt="Ijnpfm57do8uoy2cxjsc" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://oregon.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/lrgaevpvm1begoibtn9y)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/lrgaevpvm1begoibtn9y" alt="Lrgaevpvm1begoibtn9y" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<figure class='article-image'>
<div class='blurred-image'>
<a href='http://tamu.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/svugmeznwgid3uhaa7mi)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/svugmeznwgid3uhaa7mi" alt="Svugmeznwgid3uhaa7mi" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<h3 class='article-heading'>TEAMS TO WATCHING: USC and Stanford</h3>
<figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ad1f4vayuogn9ahupuni)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ad1f4vayuogn9ahupuni" alt="Ad1f4vayuogn9ahupuni" />
</div>
<figcaption class='image-caption'>Bru McCoy</figcaption>
<div class='image-credit'>Nick Lucero/Rivals.com</div>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p>The excitement swirling around <a href="https://usc.rivals.com/">USC</a>'s hiring of former <a href="https://texastech.rivals.com/">Texas Tech</a> head coach <b>Kliff Kingsbury </b>as offensive coordinator will surely be felt on the recruiting trail. The Trojans already have a pretty good haul of wide receivers and tight ends with Rivals250 prospects <a href="https://n.rivals.com/content/prospects/2019/drake-london-217395">Drake London</a> and <a href="https://n.rivals.com/content/prospects/2019/jude-wolfe-186614">Jude Wolfe</a> as well as four-stars <a href="https://n.rivals.com/content/prospects/2019/ethan-rae-182742">Ethan Rae</a> and <a href="https://n.rivals.com/content/prospects/2019/puka-nacua-105159">Puka Nacua</a>, but USC isn't done yet. Wide receiver <a href="https://n.rivals.com/content/prospects/2019/kyle-ford-32751">Kyle Ford</a>, the No. 49 player in the Rivals100 and No. 8 receiver in the new rankings, was already thought to be favoring the Trojans. Even though he is listed as an athlete, USC is recruiting five-star <a href="https://n.rivals.com/content/prospects/2019/bru-mccoy-32691">Bru McCoy</a> as a wide receiver and there is a very good chance he also ends up signing with USC.</p><p>Staying on the West Coast, <a href="https://stanford.rivals.com/">Stanford</a> has a chance to close strong. <a href="https://n.rivals.com/content/prospects/2019/elijah-higgins-188788">Elijah Higgins</a>, a big-bodied receiver out of Texas is thought to be leaning towards the Cardinal, but there are plenty of schools still coming after the four-star. The same could be said for three-star <a href="https://n.rivals.com/content/prospects/2019/cornelius-johnson-201395">Cornelius Johnson</a>. Stanford has emerged as the favorite to land his commitment, but there is a lot left to play out in his recruitment before this gets locked in.</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://stanford.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/yfqa6b22sowleqegzdpp)'></div>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/yfqa6b22sowleqegzdpp" alt="Yfqa6b22sowleqegzdpp" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://usc.rivals.com' target='_blank'>
<div class='background' style='background-image: url(https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ly4kdbbsehnwb10danbg)'></div>
<img src="https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/ly4kdbbsehnwb10danbg" alt="Ly4kdbbsehnwb10danbg" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
<h3 class='article-heading'>PROSPECT TO WATCH: Jadon Haselwood</h3>
<div class='prospect-card-article'>
<div class='prospect-profile'>
<rv-prospect-profile is-prospect-card='true' prospect-id='44232'></rv-prospect-profile>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>The one remaining uncommitted five-star wide receiver, Haselwood has the recruiting world hanging on every whisper about his recruitment. A former <a href="https://uga.rivals.com">Georgia</a> commit, the Dawgs along with <a href="https://miami.rivals.com">Miami</a> are considered the top two contenders here. He's taken countless visits to Athens to see Georgia and Miami has hosted him a number of times as well.</p><p>Auburn got Haselwood on campus in early November for an official visit. He also used two official visits to get closer looks at <a href="https://floridastate.rivals.com">Florida State</a> and Oklahoma. Those three schools seem to be a bit off the pace right now but the school that could disrupt this Georgia-Miami battle is <a href="https://tennessee.rivals.com">Tennessee</a>. Vols head coach <b>Jeremy Pruitt</b> did an in-home visit with Haselwood on Wednesday night and there is growing chatter that he could show up in Knoxville this weekend for an unofficial visit.</p><p>Haswelwood, who is planning on taking an official visit to Georgia next weekend, is an early enrollee and is scheduled to announce his commitment at the All-American Bowl on Jan. 5.</p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://rivals.com/99Cyber' target='_blank'>
<div class='background' style='background-image: url(https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/yuyvsnlvnimqnk7gasqa)'></div>
<img src="https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/yuyvsnlvnimqnk7gasqa" alt="Yuyvsnlvnimqnk7gasqa" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
</div>
<div class='text-center'>
<rv-share-links print-url='https://californiapreps.rivals.com/news/rivals-rankings-week-breaking-down-the-2019-wide-receivers/printable' site-name='CaliforniaPreps.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":2,"footballYear":2019,"basketballYear":2019},{"active":true,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2018' scoreboard-photos-id='15084' scoreboard-scores-id='15083' site='{"id":18,"legacy_id":968,"name":"CaliforniaPreps.com","friendly_name":"California HS Sports","annual_discount":null,"subdomain":"californiapreps","primary_color":"8c008c","secondary_color":"cece00","font_color":"ffffff","short_name":"californiapreps","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":null,"maple_ncaab_endpoint":null,"maple_college_id":null,"google_analytics_id":"UA-81720434-1"}' twitter-feed='{"id":18,"site_id":18,"handle":"@davekeefer","list_name":null,"created_at":"2016-02-01T12:24:44.289-06:00","updated_at":"2018-09-04T01:17:44.650-05:00","hashtags":[],"usernames":["davekeefer"],"max_number":5}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://californiapreps.rivals.com/news/rivals-rankings-week-breaking-down-the-2019-wide-receivers/printable' site-name='CaliforniaPreps.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022719647', 'https://californiapreps.rivals.com/news/rivals-rankings-week-breaking-down-the-2019-wide-receivers');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Rivals Rankings Week: Breaking down the 2019 wide receivers";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article,cross-viewed';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='doubleClickCampaignController as ctrl' ng-init='ctrl.init("rvlsartc", "californiapreps", 1991305, null)'>
<iframe frameborder='0' height='1' src='{{ ctrl.sourceUrl }}' style='display:none;' width='1'></iframe>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://californiapreps.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Oath Inc</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022719647",
    c7: "https://californiapreps.rivals.com/news/rivals-rankings-week-breaking-down-the-2019-wide-receivers"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fcaliforniapreps.rivals.com%2Fnews%2Frivals-rankings-week-breaking-down-the-2019-wide-receivers&c5=2022719647&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
